Internet Explorer 10 will not support Vista and XP

In Internet Explorer 10 Platform Preview, we see that Windows Internet Explorer 10 will not support Vista, XP too. It will only support Windows 7 and 8. Vista users are too disappointed with this news. Windows Vista Users who try to install the platform preview of Internet Explorer 10 get the message that it does not support any operating system earlier than Windows 7.




Microsoft is looking to support their newest products and trying to concentrate on Windows 7 and 8. While there are not that many Vista users left who can be irritated by Microsoft’s move to exclude their operating system from the next version of Internet Explorer, there are some who have criticized Microsoft for that decision. What do you think ? Is it fair ? Is this now Microsoft’s attempt to lure Vista users into upgrading their operating system ? Leave your comments.


Related posts